Cómo instalar Adobe Flash Player usando Ubuntu Linux Terminal

Adobe Flash Player es un complemento que está integrado con su navegador y permite al usuario transmitir o ver videos, por ejemplo, en sitios como YouTube. Hoy en día, no se requiere flash en navegadores modernos como Google Chrome y ha sido reemplazado por NPAPI, que es su versión de Flash.

Sin embargo, para Firefox navegadores, es posible que vea una ventana emergente que le pide que instale flash cuando visite algunos sitios como Vimeo y Youtube.

En este tutorial, le explicaremos cómo puede instalar el último reproductor de flash de Adobe en Ubuntu 18.04, CentOS 7 y Arch Linux desde la terminal.

Instale Adobe Flash Player en Ubuntu 18.04

Dado que el último complemento flash reside en el repositorio de Canonical y está deshabilitado de forma predeterminada, debemos habilitar el repositorio antes de instalar el complemento.

Paso 1: habilitar el repositorio canónico

Para lograr esto, ejecute el siguiente comando

add-apt-repository "deb https://archive.canonical.com/ $(lsb_release -sc) partner"

Paso 2: actualiza el sistema

A continuación, actualice el sistema

apt-get update

Paso 3: instale Adobe Flash Player

Instale el complemento Adobe Flash desde la terminal

apt install adobe-flashplugin browser-plugin-freshplayer-pepperflash

Reinicia tu Firefox navegador y vaya a https://isflashinstalled.com

Verá una página web como se muestra a continuación

Instale Adobe Flash Player 28 en CentOS 7

Dado que los complementos de Adobe Flash Player solo están disponibles en los repositorios oficiales de Adobe Yum, primero debemos habilitar el repositorio de Adobe Yum.

Paso 1: habilitar el repositorio de Yum

 rpm -ivh https://linuxdownload.adobe.com/adobe-release/adobe-release-x86_64-1.0-1.noarch.rpm

Salida de muestra

Retrieving https://linuxdownload.adobe.com/adobe-release/adobe-release-x86_64-1.0-1.noarch.rpm
warning: /var/tmp/rpm-tmp.m26n4m: Header V3 DSA/SHA1 Signature, key ID f6777c67: NOKEY
Preparing...                          ################################# [100%]
Updating / installing...
   1:adobe-release-x86_64-1.0-1       ################################# [100%]

Paso 2: importa la clave GPG en tu sistema

rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux

A continuación, instalaremos Adobe Flash Player.

Paso 3: instale Adobe Flash Player junto con sus dependencias

yum install flash-plugin alsa-plugins-pulseaudio libcurl

Salida de muestra

Dependencies Resolved

================================================================================
 Package         Arch      Version                  Repository             Size
================================================================================
Installing:
 flash-plugin    x86_64    29.0.0.140-release       adobe-linux-x86_64    8.6 M

Transaction Summary
================================================================================
Install  1 Package

Total download size: 8.6 M
Installed size: 20 M
Is this ok [y/d/N]: y
Downloading packages:
flash-player-npapi-29.0.0.140-release.x86_64.rpm           | 8.6 MB   00:44     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Installing : flash-plugin-29.0.0.140-release.x86_64                       1/1 
  Verifying  : flash-plugin-29.0.0.140-release.x86_64                       1/1 

Installed:
  flash-plugin.x86_64 0:29.0.0.140-release

Paso 3: verificación de la instalación del complemento Flash Player

Finalmente, debemos verificar si se ha instalado el complemento de Flash Player. Cierra tu Firefox o Google Chrome navegador y ejecútelo de nuevo.
Para Google Chrome navegador, abra una nueva pestaña y escriba chrome://flash/

Se mostrará la siguiente página

Para Firefox navegador, abra una nueva pestaña y escriba about:plugins
Desplácese hasta el final de la página y busque Shockwave Flash

Cómo instalar Adobe Flash Player en Arch Linux

Para instalar el complemento Adobe Flash Player en Arch Linux, primero ejecute el siguiente comando

pacman -S flashplugin

Salida de muestra

looking for conflicting packages...

Packages (1) flashplugin-29.0.0.140-1

Total Download Size:    6.93 MiB
Total Installed Size:  19.16 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 flashplugin-29.0.0....     6.9 MiB   644K/s 00:11 [----------------------] 100%
(1/1) checking keys in keyring                     [----------------------] 100%
(1/1) checking package integrity                   [----------------------] 100%
(1/1) loading package files                        [----------------------] 100%
(1/1) checking for file conflicts                  [----------------------] 100%
:: Processing package changes...
(1/1) installing flashplugin                       [----------------------] 100%
Optional dependencies for flashplugin
    libvdpau: GPU acceleration on Nvidia cards [installed]
:: Running post-transaction hooks...
(1/3) Updating icon theme caches...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Updating the desktop file MIME type cache...

A continuación, instale las dependencias

pacman -S libvdpau-va-gl

Salida de muestra

resolving dependencies...
looking for conflicting packages...

Packages (2) libva-2.1.0-1  libvdpau-va-gl-0.4.2-2

Total Download Size:   0.22 MiB
Total Installed Size:  1.01 MiB
Net Upgrade Size:      0.44 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages...
 libva-2.1.0-1-x86_64     137.6 KiB   195K/s 00:01 [----------------------] 100%
 libvdpau-va-gl-0.4....    83.8 KiB   349K/s 00:00 [----------------------] 100%
(2/2) checking keys in keyring                     [----------------------] 100%
(2/2) checking package integrity                   [----------------------] 100%
(2/2) loading package files                        [----------------------] 100%
(2/2) checking for file conflicts                  [----------------------] 100%
:: Processing package changes...
(1/2) upgrading libva                              [----------------------] 100%
(2/2) installing libvdpau-va-gl                    [----------------------] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...

Finalmente, actualice el sistema

pacman -Syu

Abre tu Firefox navegador y tipo about:plugins y verifique el complemento instalado como se mostró anteriormente.

Lea también:

  • 6 comandos para borrar la terminal de Linux
  • Cómo conectar WiFi desde la terminal en Ubuntu 16.04
  • Instalar Tilix Terminal Emulator en Ubuntu /Fedora/ Arch Linux

Las distribuciones modernas de Linux vienen con Adobe Flash Player instalado y, en la mayoría de los casos, no se le pedirá que instale el complemento flash. En resumen, le hemos mostrado cómo puede instalar el complemento Adobe Flash Player en sus distribuciones de Ubuntu, CentOS y ArchLinux. Gracias por tomarse su tiempo en este tutorial.