Cómo instalar una versión específica del paquete usando YUM

A veces, es posible que deba tener una determinada versión de un paquete instalado en su sistema para cumplir con un determinado requisito. En este artículo, veremos cómo podemos instalar versiones específicas de paquetes usando el administrador de paquetes yum en Centos & RHEL 7/8. Primero, necesitamos conocer las versiones disponibles para un paquete en particular.

Leer también: Cómo instalar una versión específica del paquete usando apt-get

Consultar versiones disponibles

Abra la terminal, ejecute el siguiente comando para ver todas las versiones disponibles de un paquete:

yum --showduplicates list

En esto example, vamos a enumerar las versiones disponibles de samba en sus repositorios habilitados para el sistema RHEL 7.

 yum --showduplicates list samba

Salida de muestra

Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Available Packages
samba.x86_64              4.1.1-31.el7                   rhui-REGION-rhel-server-releases
samba.x86_64              4.1.1-33.el7_0                 rhui-REGION-rhel-server-releases
samba.x86_64              4.1.1-35.el7_0                 rhui-REGION-rhel-server-releases
samba.x86_64              4.1.1-37.el7_0                 rhui-REGION-rhel-server-releases
samba.x86_64              4.1.1-38.el7_0                 rhui-REGION-rhel-server-releases
samba.x86_64              4.1.12-21.el7_1                rhui-REGION-rhel-server-releases
samba.x86_64              4.1.12-23.el7_1                rhui-REGION-rhel-server-releases
samba.x86_64              4.1.12-24.el7_1                rhui-REGION-rhel-server-releases
samba.x86_64              4.2.3-10.el7                   rhui-REGION-rhel-server-releases
samba.x86_64              4.2.3-11.el7_2                 rhui-REGION-rhel-server-releases
samba.x86_64              4.2.3-12.el7_2                 rhui-REGION-rhel-server-releases
samba.x86_64              4.2.10-6.el7_2                 rhui-REGION-rhel-server-releases
samba.x86_64              4.2.10-6.2.el7_2               rhui-REGION-rhel-server-releases
samba.x86_64              4.2.10-7.el7_2                 rhui-REGION-rhel-server-releases
samba.x86_64              4.4.4-9.el7                    rhui-REGION-rhel-server-releases
samba.x86_64              4.4.4-12.el7_3                 rhui-REGION-rhel-server-releases
samba.x86_64              4.4.4-13.el7_3                 rhui-REGION-rhel-server-releases
samba.x86_64              4.4.4-14.el7_3                 rhui-REGION-rhel-server-releases
samba.x86_64              4.6.2-8.el7                    rhui-REGION-rhel-server-releases
samba.x86_64              4.6.2-10.el7_4                 rhui-REGION-rhel-server-releases
samba.x86_64              4.6.2-11.el7_4                 rhui-REGION-rhel-server-releases
samba.x86_64              4.6.2-12.el7_4                 rhui-REGION-rhel-server-releases

Dado que Yum usa el administrador de paquetes RPM para manejar paquetes, los nombres de los paquetes se basan en el formato de etiqueta del paquete RPM.

En lo de arriba example, la primera columna indica el nombre del paquete y su arquitectura y la segunda columna muestra la versión del paquete. Como también notará, el paquete más reciente es el que se encuentra al final de la lista.
En este caso, samba-4.6.2-12 es el paquete más reciente.

Instalar una versión específica de un paquete

Ahora podemos proceder e instalar cualquier versión del paquete samba. Para hacer esto, ejecute, vamos a agregar la versión del paquete al final. es decir

yum install <packagename> <version>

Para instalar la última versión que es 4.6.2-12 de acuerdo con nuestro resultado como se muestra anteriormente, ejecute el siguiente comando

yum install samba-4.6.2-12

Si desea ser más específico, puede incluir el lanzamiento de la versión como se muestra

yum install samba-4.6.2-12.el7_4

Salida de muestra

--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================================================================
 Package                                 Arch                        Version                                Repository                                             Size
========================================================================================================================================================================
Installing:
 samba                                   x86_64                      4.6.2-12.el7_4                         rhui-REGION-rhel-server-releases                      633 k
Installing for dependencies:
 avahi-libs                              x86_64                      0.6.31-17.el7                          rhui-REGION-rhel-server-releases                       61 k
 cups-libs                               x86_64                      1:1.6.3-29.el7                         rhui-REGION-rhel-server-releases                      356 k
 libldb                                  x86_64                      1.1.29-1.el7                           rhui-REGION-rhel-server-releases                      128 k
 libtalloc                               x86_64                      2.1.9-1.el7                            rhui-REGION-rhel-server-releases                       33 k
 libtdb                                  x86_64                      1.3.12-2.el7                           rhui-REGION-rhel-server-releases                       47 k
 libtevent                               x86_64                      0.9.31-1.el7                           rhui-REGION-rhel-server-releases                       36 k
 libwbclient                             x86_64                      4.6.2-12.el7_4                         rhui-REGION-rhel-server-releases                      105 k
 pytalloc                                x86_64                      2.1.9-1.el7                            rhui-REGION-rhel-server-releases                       16 k
 samba-client-libs                       x86_64                      4.6.2-12.el7_4                         rhui-REGION-rhel-server-releases                      4.7 M
 samba-common                            noarch                      4.6.2-12.el7_4                         rhui-REGION-rhel-server-releases                      198 k
 samba-common-libs                       x86_64                      4.6.2-12.el7_4                         rhui-REGION-rhel-server-releases                      164 k
 samba-common-tools                      x86_64                      4.6.2-12.el7_4                         rhui-REGION-rhel-server-releases                      456 k
 samba-libs                              x86_64                      4.6.2-12.el7_4                         rhui-REGION-rhel-server-releases                      265 k

Transaction Summary
========================================================================================================================================================================
Install  1 Package (+13 Dependent packages)

Total download size: 7.2 M
Installed size: 24 M
Is this ok [y/d/N]:

Instalación completa

Installed:
  samba.x86_64 0:4.6.2-12.el7_4

Dependency Installed:
  avahi-libs.x86_64 0:0.6.31-17.el7         cups-libs.x86_64 1:1.6.3-29.el7      libldb.x86_64 0:1.1.29-1.el7              libtalloc.x86_64 0:2.1.9-1.el7
  libtdb.x86_64 0:1.3.12-2.el7              libtevent.x86_64 0:0.9.31-1.el7      libwbclient.x86_64 0:4.6.2-12.el7_4       pytalloc.x86_64 0:2.1.9-1.el7
  samba-client-libs.x86_64 0:4.6.2-12.el7_4 samba-common.noarch 0:4.6.2-12.el7_4 samba-common-libs.x86_64 0:4.6.2-12.el7_4 samba-common-tools.x86_64 0:4.6.2-12.el7_4
  samba-libs.x86_64 0:4.6.2-12.el7_4

Complete!

Nota: Excluya el paquete en el archivo de repositorio; de lo contrario, para la próxima actualización de yum se instalará la última versión

Para verificar su instalación, escriba:

rpm -qa | grep samba
samba-common-4.6.2-12.el7_4.noarch
samba-client-libs-4.6.2-12.el7_4.x86_64
samba-libs-4.6.2-12.el7_4.x86_64
samba-4.6.2-12.el7_4.x86_64
samba-common-libs-4.6.2-12.el7_4.x86_64
samba-common-tools-4.6.2-12.el7_4.x86_64

Esperamos que este artículo le haya resultado útil y que se sienta más cómodo instalando versiones específicas de paquetes con Yum en su sistema. No dude en ponerse en contacto y hacer cualquier pregunta. Gracias por tu tiempo.